WordPress phpmyadmin导出数据库出现错误break2:Fatal error: Cannot ‘break’ 2 levels in

gong'zhong'h!

昨天在操作的时候手贱,删除了某个表里面的内容,所以就准备本地恢复一下相关数据。本地使用的是PHPStudy搭建的,使用过这个软件的都知道,非常好用,很适合新手使用,同时各项设置以及配置都比较齐全,这里就不多说了。

当我通过phpmyadmin导入数据的时候是没有问题的,但是导出数据的时候就报错了,报错内容就是标题的内容,当时百度了一下,很多人的回复都是要求升级phpmyadmin版本,我表示无能为力,本地版本升级并不是解决办法,继续寻找,最终在GitHub上面找到了相关答案:

WordPress phpmyadmin导出数据库出现错误break2

也就是说这个错误是因为官方人员手误导致没有删除,后来我就找到了这个文件,进行了保存,果不其然,保存的时候就提示这个部分存在问题,应该是break,而不是break 2,所以解决办法也是非常简单的,直接将break 2;替换为break;即可。途中已经很明确了。

Leave a Reply

电子邮件地址不会被公开。 必填项已用*标注

12 − 11 =